Алгоритмы в КуМире

Содержание
  1. Как работать в программе Кумир | Программыдлякомпа.ру
  2. Настройка среды Кумир для исполнителя Робот.
  3. Стартовая обстановка Робота
  4. Что такое стартовая обстановка?
  5. Как задать стартовую обстановку?
  6. Исполнитель Робот. Простые команды.
  7. Исполнитель Робот. Циклы.
  8. Цикл со счетчиком.
  9. Давайте рассмотрим это на примере
  10. Исполнитель Робот — Среда программирования Кумир
  11. Наш Робот находится в некой среде — это клетчатое поле, размер которого известен. Так же на этом поле могут находится стены и закрашенные клетки, а сам Робот может находится в любой клетке. Так вот — стартовая обстановка задает положение Робота на поле и расположение всех остальных элементов — стен, закрашенных клеток. И перед тем, как писать алгоритм для Робота необходимо задать стартовую обстановку. Насколько это важно давайте рассмотрим на примере. Пусть есть две стартовые обстановки:
  12. Исполнение циклических алгоритмов на базе системы
  13. Презентация к уроку

Как работать в программе Кумир | Программыдлякомпа.ру

Алгоритмы в КуМире

Представьте себе клетчатое поле (как лист из тетради в клеточку) на котором находится некий объект, который мы назовем Робот.

Используя специальные команды Кумир, мы можем этим Роботом управлять — перемещать его по клеткам, закрашивать клетки.

И в большинстве случаев наша задача будет заключаться в том, чтобы написать такую программу для Робота, выполняя которую он будет закрашивать определенные клетки.

Настройка среды Кумир для исполнителя Робот.

Запущенная программа Кумир выглядит так.

Первым делом мы должны раскоментировать первую строку нашей программы, убрав символ |

Таким образом, программа станет выглядеть так:

использовать Робот

алг

нач

кон

Удалив символ |, мы тем самым указали Кумиру на то, что будем работать с исполнителем Робот. Если этого не сделать, то при написании программы мы столкнемся с ошибкой «Нет такого алгоритма». Поэтому очень важно при создании новой программы раскоментировать первую строку. Теперь все готово для дальнейшей работы.

Но перед началом, нам необходимо задать стартовую обстановку Робота и познакомиться с простыми командами исполнителя Робот.

Стартовая обстановка Робота

Перед началом выполнения программы необходимо задать исполнителю Робот стартовую обстановку. Это значит установить Робота в нужную позицию, расставить стены, закрасить нужные клетки и т. п. Этот шаг очень важен. Если его проигнорировать, то программа может работать неправильно или вообще завершится аварийно.

Что такое стартовая обстановка?

Наш Робот находится в некой среде — это клетчатое поле, размер которого известен. Так же на этом поле могут находится стены и закрашенные клетки, а сам Робот может находится в любой клетке.

Так вот — стартовая обстановка задает положение Робота на поле и расположение всех остальных элементов — стен, закрашенных клеток. И перед тем, как писать алгоритм для Робота необходимо задать стартовую обстановку.

Насколько это важно давайте рассмотрим на примере. Пусть есть две стартовые обстановки:

Отличаются они только тем, что в стартовой обстановке 2 справа от Робота находится стена.

Если наша программа начнется с команды, которая переместит Робота на одну клетку вправо (о простых командах Робота), то в первом случае (стартовая обстановка 1) Робот выполнит эту команду, а во втором программа завершится аварийно, так как Робот не может ходить сквозь стены. Получается, что одна и та же программа в первом случае работает, а во втором приводит к ошибке. Именно поэтому так важно задавать стартовую обстановку для Робота.

Как задать стартовую обстановку?

Запустив среду Кумир в меню Инструменты выбираем пункт Редактировать стартовую обстановку Робота.

Откроется окно с синим фоном. Это и есть стартовая обстановка Робота. И мы ее можем изменить.

По-умолчанию, размер окна 10 на 15 клеток. Если нам необходимо изменить количество строк и столбцов, то щелкаем Обстановка -> Новая обстановка и задаем необходимые значения

Далее,

  • чтобы переместить Робота в новую позицию, щелкаем по нему левой кнопкой мыши и не отпуская ее тащим Робота в нужное место.
  • чтобы добавить/удалить стену, щелкаем левой кнопкой мыши по границе клетки.
  • чтобы закрасить/очистить клетку, щелкаем по ней левой кнопкой мыши
  • чтобы добавить или убрать точку в клетку щелкаем по клетке, удерживая клавишу Ctrl

После того, как мы задали нужную стартовую обстановку, ее необходимо сохранить (Обстановка -> Сохранить или Обстановка -> Сохранить как). После этого закрываем окно Обстановка и в основном окне программы выбираем Робот -> Сменить стартовую обстановку

Находим сохраненную ранее обстановку и загружаем ее. После этого убедимся, что загрузили правильную стартовую обстановку, щелкнув по кнопке Показать окно Робота

Если в окне с зеленым фоном (текущая обстановка Робота) вы увидите вашу обстановку, то можно переходить к написанию алгоритма, используя простые команды Робота.

Исполнитель Робот. Простые команды.

У нашего Робота тоже есть система команд. Сегодня мы рассмотрим простые команды Робота. Всего их 5:

вверх

вниз

влево

вправо

закрасить

Результат выполнения этих команд понятен из их названия:

вверх — переместить Робота на одну клетку вверх

вниз — переместить Робота на одну клетку вниз

влево — переместить Робота на одну клетку влево

вправо — переместить Робота на одну клетку вправо

закрасить — закрасить текущую клетку (клетку в которой находится Робот).

Эти команды можно писать с клавиатуры, а можно использовать горячие клавиши (нажав их команды будут вставляться автоматически):

вверх — Escape, Up (стрелка вверх)

вниз — Escape, Down (стрелка вниз)

влево — Escape, Left (стрелка влево)

вправо — Escape, Right (стрелка вправо)

закрасить — Escape, Space (пробел)

Обратите внимание, что набирать нужную комбинацию горячих клавиш нужно не привычным нам способом! Мы привыкли нажимать клавиши одновременно, а здесь их нужно нажимать последовательно.

Теперь мы готовы написать первый алгоритм для Робота. Предлагаю начать с простого — нарисуем квадрат со стороной 3 клетки. Поехали!

Запускаем Кумир, настраиваем его. Можно начинать писать программу? Конечно нет! Мы же не задали стартовую обстановку! Делаем это. Предлагаю использовать вот такую:

Вот теперь все готово. Начинаем писать программу. Пока она выглядит так

Удаляем символ «|» и называем наш алгоритм «Квадрат»

Предлагаю рисовать квадрат, двигаясь по часовой стрелке. Для начала закрасим текущую клетку, дав команду закрасить. Потом делаем шаг вправо и опять закрашиваем клетку. И еще раз шаг вправо и закрасить.

Попробуем запустить программу и посмотреть что же получилось. Для запуска нажимаем F9 или же кнопку на панели инструментов

В результате мы должны увидеть вот такую картину

Если такое окно Робота у вас не появилось, то на панели инструментов щелкните «Показать окно Робота» или в меню Робот выберите пункт «Показать окно Робота». Продолжаем дальше.

Теперь мы будем двигаться вниз и закрашивать правую сторону квадрата:

вниз

закрасить

вниз

закрасить

Потом пойдем влево, закрашивая нижнюю границу квадрата

влево

закрасить

влево

закрасить

У нас осталась одна не закрашенная  клетка. Закрасим ее

вверх

закрасить

Все готово! В итоге наша программа выглядит так:

использовать Робот

алг Квадрат

нач

закрасить

вправо

закрасить

вправо

закрасить

вниз

закрасить

вниз

закрасить

влево

закрасить

влево

закрасить

вверх

закрасить

кон

А результат ее работы вот так

Итак, сегодня мы с вами написали программу, используя простые команды Робота. Рекомендую попрактиковаться самостоятельно — придумать себе задание и написать программу.

Это могут быть самые различные фигуры, узоры, буквы. К примеру, попробуйте написать программу, рисующую букву П, Р, Ш, Щ, М.

А если получится и захотите поделиться — комментируйте и прикрепляйте результат к комментарию.

Исполнитель Робот. Циклы.

Итак, что такое цикл? Представьте, что мы находимся на уроке физической культуры и перед нами стоит задача сделать 7 приседаний. Это задание можно оформить в виде линейного алгоритма и тогда оно будет выглядеть примерно так:

сделай приседание

сделай приседание

сделай приседание

сделай приседание

сделай приседание

сделай приседание

сделай приседание

То есть мы повторили команду сделай приседание 7 раз. А есть ли смысл писать 7 одинаковых команд? Может проще дать команду сделай 7 приседаний? Конечно проще и правильнее. Это и есть цикл. Вы можете сами вспомнить примеры циклов из жизни — их довольно много.

Таким образом линейный алгоритм, где повторяются одни и те же команды мы можем оформить в виде циклического алгоритма — примерно так:

повторяй 7 раз

сделай приседание

конец цикла

Вот так, на придуманном нами языке мы оформили цикл. У исполнителя Робот тоже есть возможность записывать циклы. Причем, циклы бывают разные. Тот вариант, который мы только что рассмотрели называется цикл со счетчиком или цикл с параметром.

Цикл со счетчиком.

Цикл со счетчиком применяется когда заранее известно сколько повторений необходимо сделать. В примере выше с приседаниями именно такой случай.

Для того, чтобы написать цикл со счетчиком для исполнителя необходимо знать его синтаксис. А он такой:

нц раз

кц

Здесь мы должны указать количество повторений (число) и команды, которые будут повторяться.  Команды, которые повторяются в цикле называют телом цикла.

Давайте рассмотрим это на примере

Закрасим 7 клеток, как на рисунке. Рекомендую почитать про стартовую обстановку Робота и про его простые команды.

Изначально Робот находился в левой верхней клетке.

Давайте для начала решим задачу линейно. В этом случае мы будет закрашивать текущую клетку и перемещаться на 1 клетку вправо и программа будет выглядеть так:
использовать Робот
алг
нач

закрасить

вправо

закрасить

вправо

закрасить

вправо

закрасить

вправо

закрасить

вправо

закрасить

вправо

закрасить

вправо

кон

Как видим, команды закрасить и вправо повторяются 7 раз. Давайте теперь перепишем программу с использованием цикла.

Кстати, чтобы вставить цикл в свою программу можно в меню Вставка выбрать пункт нц-раз-кц или нажать одну из комбинаций клавиш Esc, Р (русская буква Р) или Esc, H (латинская буква H). Причем клавиши надо нажимать последовательно — сначала Esc, отпустить ее и только потом Р или H.

Так вот, наша программа с циклом будет выглядеть так:

использовать Робот

алг

нач

нц 7 раз

закрасить

вправо

кц

кон

Если мы ее запустим, то увидим, что в результате получится тоже самое — 7 закрашенных клеток. Однако программа стала короче и значительно грамотней с алгоритмической точки зрения!

Источник: https://programmydlyacompa.ru/kak-rabotat-v-programme-kumir/

Исполнитель Робот — Среда программирования Кумир

Алгоритмы в КуМире

Кто такой исполнитель Робот?

Настройка среды Кумир для исполнителя Робот.

Запущенная программа Кумир выглядит так.

Первым делом мы должны раскомментировать первую строку нашей программы, убрав символ |

Таким образом, программа станет выглядеть так:

использовать Робот

алг

нач

кон

Удалив символ |, мы тем самым указали Кумиру на то, что будем работать с исполнителем Робот. Если этого не сделать, то при написании программы мы столкнемся с ошибкой «Нет такого алгоритма». Поэтому очень важно при создании новой программы раскомментировать первую строку. Теперь все готово для дальнейшей работы.

Но перед началом, нам необходимо задать стартовую обстановку Робота и познакомиться с простыми командами исполнителя Робот.

Стартовая обстановка Робота

Перед началом выполнения программы необходимо задать исполнителю Робот стартовую обстановку. Это значит установить Робота в нужную позицию, расставить стены, закрасить нужные клетки и т. п. Этот шаг очень важен. Если его проигнорировать, то программа может работать неправильно или вообще завершится аварийно.

Наш Робот находится в некой среде — это клетчатое поле, размер которого известен. Так же на этом поле могут находится стены и закрашенные клетки, а сам Робот может находится в любой клетке. Так вот — стартовая обстановка задает положение Робота на поле и расположение всех остальных элементов — стен, закрашенных клеток. И перед тем, как писать алгоритм для Робота необходимо задать стартовую обстановку. Насколько это важно давайте рассмотрим на примере. Пусть есть две стартовые обстановки:

Стартовая обстановка 1Стартовая обстановка 2

Отличаются они только тем, что в стартовой обстановке 2 справа от Робота находится стена.

Если наша программа начнется с команды, которая переместит Робота на одну клетку вправо (о простых командах Робота), то в первом случае (стартовая обстановка 1) Робот выполнит эту команду, а во втором программа завершится аварийно, так как Робот не может ходить сквозь стены. Получается, что одна и та же программа в первом случае работает, а во втором приводит к ошибке. Именно поэтому так важно задавать стартовую обстановку для Робота.

Исполнение циклических алгоритмов на базе системы

Алгоритмы в КуМире

Цели: сформировать умение записи, исполнения и отладки алгоритмов с использованием цикла пока; добиться понимания использования цикла пока; развивать умение анализировать.

Ученики должны знать: правила записи и исполнения цикла пока; свойства цикла пока.

Ученики должны уметь: использовать при составлении алгоритмов конструкцию цикла пока и записывать ее на языке Кумир, владеть методами отладки: по шагам, непрерывно.

Метод обучения: объяснительно-иллюстративный и репродуктивный (на этапе объяснения нового материала), репродуктивный с элементами проблемного (этап закрепления материала).

Обеспечение урока:

  • система Кумир;
  • интерактивная доска;
  • мультимедийный проектор;
  • карточки-задания.

Ход урока

1. Объяснение нового материала.

В общем случае алгоритм должен быть универсальным, т.е., он не должен зависеть от расстояния между Роботом и стеной. Для этого в алгоритмическом языке есть специальная команда – цикл пока.

Общий вид цикла пока

В общем виде цикл пока записывается так:

При выполнении цикла компьютер повторяет следующие действия:

а) проверяет записанное после служебного слова пока условие;

б) если условие не соблюдается, то выполнение цикла завершается, и компьютер начинает выполнять команды, записанные после кц. Если же условие соблюдается, то компьютер выполняет тело цикла, снова проверяет условие и т.д.

Пример.

Метод отладки: по шагам.

Диалог Компьютера и Робота

Компьютер: снизу свободно?

Робот: да.

Компьютер: вниз.

Робот: смещается вниз в клетку Б.

Компьютер: снизу свободно?

Робот: да.

Компьютер: вниз.

Робот: смещается вниз в клетку В.

Компьютер: снизу свободно?

Робот: нет.

Так как Робот ответил нет, т.о. записанное после пока условие не соблюдается и выполнение цикла заканчивается.

Продемонстрировать в системе Кумир методы отладки: по шагам и непрерывно.

Тело цикла может не выполниться ни разу, если условие в цикле пока не соблюдается с самого начала. Например, если в алгоритме «вниз до стены» Робот на первый же вопрос «снизу свободно » ответит нет, то компьютер не вызовет команду «вниз» ни разу.

Зацикливание. Выполнение цикла пока может и не завершиться, если условие все время будет соблюдаться. Например, если ниже Робота никаких стен нет, то при выполнении предыдущего алгоритма, компьютер «зациклится», т.е. будет бесконечно спрашивать у Робота «снизу свободно», получать в ответ да и командовать «вниз».

Выполнение упражнений.

2. Эксперименты с программой на примере исполнителя Робот.

Необходимо, в системе Кумир, предварительно сделать заготовки расположения Робота (файлы 1.fil-6.fil).

Упражнения.

Эксперименты с программой.

Задание 1. (Загрузить файл 1.fil)

Требуется перевести Робота из клетки А в клетку Б. Использовать цикл пока:

использовать Робот

Задание 2. (Загрузить файл 2.fil)

Дано, что Робот находится у левой стены внутри прямоугольника, огороженного со всех сторон стенами. Внутри прямоугольника стен нет, размеры прямоугольника неизвестны. Требуется закрасить горизонтальный ряд клеток от исходного положения Робота до правой стены и вернуть Робота в исходное положение.

Задание 3. (Загрузить файл 3.fil)

Робот находится в горизонтальном коридоре. Закрасить все клетки коридора:

Задание 4. (Загрузить файл 4.fil)

1. Переделайте алгоритм «закрасить ряд вправо и вернуться» используя в нем цикл:

2. Используя вспомогательный алгоритм, составьте алгоритм, при выполнении которого Робот закрашивает прямоугольник.

Задание 5. (Загрузить файл 5.fil)

Составьте алгоритм для закраски всех клеток вокруг прямоугольной стены:

Задание 6. ( Загрузить файл 6.fil) (Из материалов экзамена 2009г.)

Робот находится в левом верхнем углу огороженного пространства, имеющего форму прямоугольника. Размеры прямоугольника неизвестны. Написать для Робота алгоритм, закрашивающий четыре угловые клетки прямоугольника.

Задание 7. (Загрузить файл 6.fil) (Из материалов экзамена 2009 г.)

Робот находится в левом верхнем углу огороженного пространства, имеющего форму прямоугольника. Размеры прямоугольника неизвестны. Написать для Робота алгоритм, закрашивающий все клетки, расположенные внутри прямоугольника и прилегающие к нижней стороне прямоугольника.

3. Закрепление. Вопросы:

Какие команды Компьютер будет давать Роботу при выполнении цикла:

а) нц пока клетка не закрашена

закрасить

кц

б) нц пока клетка закрашена

закрасить

кц

В ситуации, когда Робот стоит:

  1. в закрашенной клетке,
  2. в не закрашенной?

Расположение Робота показано на следующих рисунках:

Как будет выполняться цикл?

Домашнее задание. Определите значение переменной S после выполнения операторов:

Литература: А.Г.Кушниренко «Основы информатики и вычислительной техники».

19.04.2010

Источник: https://urok.1sept.ru/%D1%81%D1%82%D0%B0%D1%82%D1%8C%D0%B8/567694/

Презентация к уроку

Алгоритмы в КуМире

Инфоурок › Информатика ›Презентации›Презентация к уроку «Вычислительные алгоритмы в среде Кумир»

Описание презентации по отдельным слайдам:

1 слайдОписание слайда:

Вычислительные алгоритмы в среде Кумир Подготовила: Корчуганова М.Р., учитель информатики МБНОУ “ГКЛ”

2 слайдОписание слайда:

Исполнитель Компьютер Память – для хранения данных, команд и операций Процессор – для исполнения команд и вычислений операций

3 слайдОписание слайда:

Данные, которые могут храниться в компьютере Целые числа Вещественные числа (десятичная дробь) Символы Литеральный (строка символов) Логический

4 слайдОписание слайда:

Алгоритмический язык (среда Кумир) Переменные цел a вещ b сим K лит X[1:10] лог F Константы 12, -34, $100 1e+4, 23.5, -6.4e-7 ‘1’, “Д” ‘YES’, “ДА” да, нет   Тип целый вещественный символьный строка логический

5 слайдОписание слайда:

  Операции с целыми числами: div(а,2) – целое от деления a на 2 mod(а,2) – остаток от деления а на 2 iabs(a) – абсолютное значение |a| а+2 – сложение а с 2 а*2 – умножение а на 2 а-2 – вычитание из а 2 а**2 – возведение а в степень 2

6 слайд 7 слайдОписание слайда:

  Операции со строками: K+’я’ – добавление к символу K символ ’я’ Х+’ мир’ – добавление к строке Х строки ’ мир’ Х[2:3] – вырезать из строки Х строку, начиная со 2 и заканчивая 3 символом лит_в_вещ(Х, F), лит_в_цел(X, F) – строку, состоящую из цифр перевести в число (вещественное или целое), F – результат успеха вещ_в_лит(b), цел_в_лит(a) – перевод числовых данных в литерный (строку)

8 слайдОписание слайда:

  Операции сравнения (в результате получим да или нет): 0 < 2 – меньше 5 > 2 – больше 2=3 – больше или равно 01 – не равно 1=1 – равно Операции с логическими данными: и – логическое умножение (конъюнкция) или – логическое сложение (дизъюнкция) не – логическое отрицание (инверсия)

9 слайдОписание слайда:

Команды ввода, вывода, присваивания, условия и выбора: ввод а вывод “а=“, a, нс а:=а+2 если а0 а:=а-2 кц вывод а цел с; с:=0 нц ввод а; с:=с+а кц при а=0 вывод а

11 слайдОписание слайда:

Линейные алгоритмы Обмен значениями двух переменных С использованием дополнительной переменной Без использования дополнительной переменной, но с использованием арифметических операций: +, -, *, /

12 слайдОписание слайда:

Команды ввода, вывода, присваивания ввод а вывод “а=“, a, нс а:=а+2

13 слайд 14 слайдОписание слайда:

Постройте алгоритм деления обыкновенных дробей Вывод организуйте в виде: 1/2:3/4=4/6   Подсказка: вывод a,”/”,b,”:”,c,”/”,d,”=“, m,”/”,n Выведите число в виде десятичной дроби

15 слайдОписание слайда:

Алгоритм «Черный ящик» На входе подается любое целое число, а на выходе – сообщение: Определите алгоритм и напишите программу, ее реализующую. Вход Выход 5 -1 0 3 11 -1 1 7

16 слайдОписание слайда:

Упражнение Придумайте свой алгоритм «Черного ящика» с использованием не более двух арифметических операций и реализуйте его. Если число четное, то вывести 1, иначе – 2 (Реализация без команды условия: в:=mod(a,2)+1) Если число отрицательно, то вывести -1, иначе – 1 (Реализация без команды условия: в:=sqrt((a+0.1)**2)/(a+0.1))

17 слайдОписание слайда:

Домашнее задание Стр.190 №6-9 Напишите алгоритм сложения двух простых дробей (без сокращения дроби) Напишите алгоритм вычисления y по формуле: y=(1-x2+5×4)2, где х – заданное целое число. Учтите следующие ограничения: можно использовать только операции +,-,*; каждое выражение содержит только одну операцию. Выполните трассировку при х=2. Все домашние задания из учебника Семакина 9 класс

18 слайдОписание слайда:

Напишите алгоритм вычисления y=x8; y=x10; y=x15; y=x19, где х – заданное целое число. Учтите следующие ограничения: можно использовать только операции +,-,*; каждое выражение содержит только одну операцию.

Постарайтесь использовать минимальное количество дополнительных переменных. Выполните трассировку при х=2.

Напишите алгоритм циклического обмена значениями трех переменных A, B, C по схеме: Например, для A=1, B=2, C=3 должно быть: A=3, B=1, C=2. A B C

19 слайдОписание слайда:

Разветвляющиеся алгоритмы Проверка условия команды команды Да Нет

20 слайдОписание слайда:

Команды условия и выбора если а0 b:=1; N:=N-1 N>0 c:=a+b; a:=b; b:=c; N:=N-1 a:=b Вывод a конец нет нет

33 слайдОписание слайда:

Виды циклов Виды циклов Цикл с параметром счетчика Цикл с предусловием Цикл с постусловием Счетчик Тело цикла Условие продолжения цикла Тело цикла Тело цикла Условие окончания цикла

34 слайдОписание слайда:

Команды цикла на алгоритмическом языке нц 5 раз вывод “+” кц цел к нц для к от 1 до 10 шаг 2 ввод а вывод а**к кц а:=10 нц пока а>0 а:=а-2 кц вывод а с:=0 нц ввод а с:=с+а кц при а=0 вывод а 1. Со счетчиком 2.

С параметром счетчика 3. С предусловием 4.

С постусловием С каждым типом цикла отработайте разные варианты: Измените числовые и символьные данные, арифметические операции Переместите команду ввода и вывода Определите, что делает цикл

35 слайдОписание слайда:

Блок-схема вычисления N! алг факториал нач цел N, F, R ввод N F:=1 R:=1 нц пока R0 то b:=1; N:=N-1 нц пока N>0 c:=a+b; N:=N-1 a:=b b:=c кц a:=b все вывод a кон Алгоритм начало Ввод N a:=1; N:=N-1 N>0 b:=1; N:=N-1 N>0 c:=a+b; a:=b; b:=c; N:=N-1 a:=b Вывод a конец нет нет

37 слайдОписание слайда:

Упражнение Придумайте свою последовательность из чисел или символов и постройте алгоритм получения этой последовательности с использованием цикла. Например: 1, 2, 4, 8, 16, 32, …

38 слайдОписание слайда:

Домашнее задание Стр. 218, №7-8 Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N. Проверьте алгоритм трассировкой. Дано целое число Х и натуральное число N. Составьте алгоритм вычисления ХN. Проверьте алгоритм трассировкой.

39 слайдОписание слайда:

Вспомогательные алгоритмы алг ПОДПРОГРАММА нач лит s строка (”+”, 5, s) вывод s кон алг строка (арг сим а, арг цел к, рез лит в) нач в:=”” нц к раз в:=в+а кц кон алг ФУНКЦИЯ нач вывод строка(”+”, 5) кон алг лит строка (сим а, цел к) нач знач:=”” нц к раз знач:=знач+а кц кон Чем отличается подпрограмма и функция? Используя вспомогательные алгоритмы выведите буквы вашего имени несколько раз подряд: ИИИИМММММЯЯЯЯ Используя вспомогательные алгоритмы выведите строку: ******——+++++!!!!!!!!! Используя вспомогательные алгоритмы создайте рисунок из символов *

40 слайдОписание слайда:

Алгоритм Евклида Составить подпрограмму Алгоритм Евклида(арг цел а, арг цел б, рез цел с)

41 слайдОписание слайда:

Упражнение Составьте функцию НОД (m,n) по алгоритму Евклида и вызовите ее из основной программы: алг цел НОД (цел m, цел n) нач … знач:=m кон С какими трудностями вы столкнулись? (нельзя аргумент функции изменять в теле функции) Как решили проблему? (переприсвоили другим переменным, которые объявили в теле функции) Составить функцию вычисления НОК(m,n) – наименьшее общее кратное двух чисел

42 слайдОписание слайда:

Домашнее задание Стр. 222, №2-3 Составьте алгоритм нахождения наибольшего общего делителя трех чисел, используя формулу: НОД(A, B, C)= НОД(НОД(A, B), C) Составьте алгоритм нахождения наименьшего общего кратного (НОК) двух чисел, используя формулу: А∙В = НОД(А, В) ∙ НОК(А, В)      

43 слайдОписание слайда:

Таблица Пифагора (таблица умножения) a\b 2 3 4 5 6 7 8 9 2 3 4 5 a*b 6 7 8 9 используя вложенные циклы

44 слайдОписание слайда:

Треугольник Паскаля 0 1 1 1 1 2 1 2 1 3 1 3 3 1 4 1 4 6 4 1 5 1 5 10 10 5 1 н/к 0 1 2 3 4 5 С(н,к)=н!/(к!(н-к)!) используйте описание функции для вычисления факториала(н) и С(н,к)

45 слайдОписание слайда:

Табличные данные (массивы) Описание цел таб Р[-5:5] вещ таб Т[1:4, 1:12] Ввод нц для н от -5 до 5 ввод Р[н] кц нц для н от 1 до 4 нц для м от 1 до 12 ввод Т[н, м] кц кц Вывод нц для н от -5 до 5 вывод Р[н], “ “ кц нц для н от 1 до 4 нц для м от 1 до 12 вывод Т[н, м], “ “ кц вывод нс кц Имена массиву лучше давать с заглавной буквы

46 слайдОписание слайда:

Алгоритмы с массивами Определение наибольшего/ наименьшего числа в массиве Нахождением суммы/произведение элементов массива Определение среднего значения Поиск числа в массиве Переставить элементы массива в обратном порядке Упорядочивание элементов в массиве

47 слайдОписание слайда:

цел n,н ввод n цел таб А[1:n] нц для н от 1 до n ввод A[н] кц Массив переменной длины напишите вывод массива

48 слайдОписание слайда:

Алгоритм нахождения наибольшего значения элементов массива макс:=А[1] нц для к от 2 до n если A[к]>макс то макс:=A[к] все кц 1. напишите вывод максимального элемента массива в виде: макс=5 2. напишите алгоритм нахождения минимального элемента массива

49 слайдОписание слайда:

Алгоритм нахождения суммы элементов массива сумма:=0 нц для к от 1 до n сумма:=сумма+A[к] кц напишите алгоритм нахождения произведения элементов массива

50 слайдОписание слайда:

Алгоритм нахождения среднего значения элементов массива сумма:=0 нц для к от 1 до n сумма:=сумма+A[к] кц =сумма/11 исправьте алгоритм

51 слайдОписание слайда:

Алгоритм поиска элемента в массиве ввод а н:=0 нц для к от 1 до n если A[к]=а то н:=н+1 все кц проверьте для случая, когда — одно совпадение — несколько совпадений — такого элемента нет

52 слайдОписание слайда:

Домашнее задание Стр. 227, №3-4 Для входных данных значений температуры за предыдущий год по месяцам составьте алгоритм вычисления средних температур зимних, весенних, летних, осенних месяцев.

Вы посетили магазин и купили 10 видов товаров. В таблицу Т[1:10] записали количество купленного товара каждого вида, а в таблицу С[1:10] – цены единиц каждого вида товара соответственно.

Составьте алгоритм вычисления общей стоимости всех покупок.

53 слайдОписание слайда:

Стр. 231, №1-5 Напишите алгоритм ввода численности населения Москвы к концу каждого года XX века. Напишите алгоритм ввода веса котенка в течение месяца.

Составьте алгоритм получения среднего арифметического введенных температур за год и нахождения массива отклонений от средней температуры по каждому месяцу. 1-2.

Придумайте и реализуйте алгоритм по работе с этими данными: поиск наибольшего/наименьшего значения, поиск среднего арифметического и т.д.

54 слайдОписание слайда:

Алгоритм перестановки элементов массива в обратном порядке m:=div(n,2) нц для к от 1 до m а:=A[к]; A[к]:= A[n-к+1]; A[n-к+1]:=а кц 1. напишите вывод полученного массива 2. что будет, если вместо m в цикле поставить n — количество элементов в массиве

55 слайдОписание слайда:

Алгоритм упорядочивания элементов массива по возрастанию На входе дан числовой массив: 1 2 5 11 -5 8 10 0 9 4 На выходе должны получить: -5 0 1 2 4 5 8 9 10 11 Как это сделать? Разбиваем на несколько групп по 2-3 человека, которые в процессе обсуждения выводят этот алгоритм.

56 слайдОписание слайда:

Алгоритмы сортировки Сортировка вставками Сортировка выбором Сортировка пузырек (обменом) Сортировка челнок (обменом)

57 слайдОписание слайда:

Домашнее задание Примените алгоритм упорядочивания элементов массива, состоящего из литерных данных (слов).

Общая информация

Источник: https://infourok.ru/prezentaciya-k-uroku-vichislitelnie-algoritmi-v-srede-kumir-3061987.html

Booksm
Добавить комментарий